Financial Report

Annual Audit Report

Action required : Security update for WooCommerce Payment Gateway.

Hi there, 

To address a security vulnerability, we released an important security patch for WooCommerce (versions 8.8.5 and 8.9.3) on June 10, 2024. Your website requires an immediate update to the latest version of WooCommerce. If exploited, this vulnerability could allow bad actors to manipulate a website link to inject malicious content.

We always encourage merchants to maintain high security standards and update plugins and web pages monthly. This includes the use of strong passwords, two-factor authentication, careful monitoring of website, and using the latest, secure version of WooCommerce (and any other extensions or plugins installed on your site). Read more about security best practices.